Function syntax for calling modes on entries.
|Date: 2013-03-01 01:59:07||Priority: Moderate|
: Cadre Bugs
Not sure how to write this exactly. I'm guessing with the spirit of #2073
, though, it'd be OK if they just were overridden by valid function variables.
Think underscores. It parallels the underscore notation used for core table columns.
But it does get a bit confusing when you can't call @_this._view with just _view(), but you can call @_this._body with just _body.
We need a new prefix for dynamic functions.
To finish the process: getvar() given an undefined _-prefixed live data element should search for a matching mode, and pass back an object representing this if one is found. procman can then interpret this next to where the barefunc code is kept.
Or maybe you're overthinking things—what if modes just supersede dynamic functions?
Totally unused sigils: #, $, ~, `, ?, :
I can't believe I listed $. Why would I list $?!